Home Excel - Formulas e Funções Excel Formulas - SomarProduto Excel formula somarproduto e soma determinadas colunas

Excel formula somarproduto e soma determinadas colunas

E-mail Imprimir PDF

Saberexcel - o site de quem precisa aprender Macros Microsoft Excel VBA

Essa função do Aplicativo Microsoft Excel, SOMARPRODUTO() E SOMA(), conjuntamente com outras função como podemos observar na fórmula, soma valores de determinada folha de planilha neste caso somamos colunas na folha de Planilha 'BD'.

'------------------------'
'=SOMARPRODUTO((INDIRETO("BD!C"&TEXTO(C4+3;0)&":C"&TEXTO(C5+3;0))))
'=SOMARPRODUTO((INDIRETO("BD!D"&TEXTO(D4+3;0)&":D"&TEXTO(D5+3;0))))
'-------------------------'
'=SOMA((INDIRETO("BD!C"&TEXTO(C4+3;0)&":C"&TEXTO(C5+3;0))))
'=SOMA((INDIRETO("BD!D"&TEXTO(D4+3;0)&":D"&TEXTO(D5+3;0))))
'-------------------------'

Para um melhor entendimento baixe o exemplo de planilha no final da página.
Espero que o exemplo possa lhe ser útil. Fique com Deus, Expedito Marcondes




Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel



  Baixe o exemplo de planilha contendo as fórmulas acima.
Excel formula somarproduto e soma determinadas colunas (74.29 KB)

Duvida Abaixo: resposta:
http://www.microsoftexcel.com.br/index.php/excel-dicas-microsoft-excel-vba/137-excel-vba-numeros/1354-excel-planlha-vba-numeros-e-textos-funcao-extrair.html
Fique com Deus,
Expedito Marcondes.

Última atualização em Sáb, 27 de Abril de 2013 21:09  

Comentários  

 
# Riomar 09/04/2013 12:42
calcular célula contento número e texto
ex. na célula A1 contem 200
na célula B1 contem kg
na célula C1 resulta A1+B1 = 200kg
na célula D1 contem 3 que é o valor unitário
na célula E1 resultado de C1*D1=600kg
Responder | Responder com citação | Citação
 
 
# Expedito Marcondes_ 27/04/2013 19:51
Prezado Riomar,
Na concatenação dos dados na coluna(B),
vai gerar um erro se multiplicar (Textos por números)
Então temos que isolar o texto do Número
//==========='
USANDO UMA FUNÇÃO PERSONALIZADA PARA SEPARAR O NÚMERO
DO TEXTO:
//===========' Resposta:
a1 = 200
b1 = Kg =CONCATENAR(A1;B1)
c1 = 200Kg
e1 = 600 =ESQUERDA(C1;3)*D1
ou
e1 = 600 =Extrair_Numero( C1)*D1 ' mais indicado
//==========='
Function Extrair_Numero( vCell As Range)
Dim vContador As Long, l As Long
Dim vTexto As String
Dim vNum As String
vTexto = vCell
For vContador = Len(vTexto) To 1 Step -1
If IsNumeric(Mid(v Texto, vContador, 1)) Then
l = l + 1
vNum = Mid(vTexto, vContador, 1) & vNum
End If
If l = 1 Then vNum = CInt(Mid(vNum, 1, 1))
Next vContador
Extrair_Numero = CLng(vNum)
End Function
' - - - - -
Sub chamando_funcao _via_vba()
For i = 2 To Cells(Rows.Count, "A").End(xlUp).Row
Cells(i, "F").Value = CDbl(Extrair_Nu mero( Cells(i, "c")) * Cells(i, "d"))
Next i
End Sub
'- - - - - - - -
Sub Limpar_teste()
Range("F2:F" & Range("A65000").End(xlUp).Row).ClearContents
End Sub
'- - - - - - - -
baixe o exemplo de planihas
http://www.microsoftexcel.com.br/index.php/excel-dicas-microsoft-excel-vba/137-excel-vba-numeros/1354-excel-planlha-vba-numeros-e-textos-funcao-extrair.html
Responder | Responder com citação | Citação
 

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje3979
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana23485
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês37214
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10460043
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA