Home Excel - Formulas e Funções Excel Formulas - SomarProduto Excel planilha formulas somarproduto soma celulas alternadas

Excel planilha formulas somarproduto soma celulas alternadas

E-mail Imprimir PDF

Saberexcel - o site das macros

Essa função do Aplicativo Microsoft Excel, Somarproduto, soma células alternadas em determinada coluna, neste caso usei também um range dinâmico com intúíto didático. os range dinamicos expandem o tamanho com a digitação.

Fórmula usada.:
'=SOMARPRODUTO(B1:B15*(MOD(LIN(B1:B15);2)))

Fórmula usada.:
'=SOMARPRODUTO(vRegiao*(MOD(LIN(vRegiao);2)))

'Range dinâmico nomeado como 'vRegiao'
'Range dinâmico expande o tamanho de acordo com a digitação.
'=DESLOC(Plan1!$B$1;;;CONT.VALORES(Plan1!$B:$B))




Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, praticando com os produtos didáticos Saberexcel.




Última atualização em Qua, 31 de Outubro de 2012 08:55  

Comentários   

 
marcosascggoncalves
# marcosascggoncalves 27-02-2014 17:21
para ir inserindo valores na coluna b e ir aparecendo o total na coluna c. cada uma com seu resultado no total de 101 linhas. tem como? pode me dar o código vba?
Responder | Responder com citação | Citar
 
 
Expedito Marcondes.
# Expedito Marcondes. 28-02-2014 13:11
Prezado Marcos, boa tarde,
Segue o link de um exemplo de planilha com macros usando a insdeusepaição for next, e também o evento change da folha de planlha para somar automaticamente com a digtação em uma determinada coluna e retornando a soma para uma célula neste caso a célula (c1)
microsoftexcel.com.br/.../...
fique com Deus, Expedito Marcondes
Escola Saberexcel VBA Estudos®
Responder | Responder com citação | Citar
 
 
marcosascggoncalves
# marcosascggoncalves 28-02-2014 11:03
não esta dando certo estas fórmulas. quero digitar na coluna b e já aparecer somado na coluna c. a medida que digito na coluna b já automaticamente aparece a soma na coluna c.
Responder | Responder com citação | Citar
 

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar


Google Associados

Depoimentos

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA