Home Excel - Formulas e Funções Excel Formulas - SomarProduto Excel planilha formula somarproduto por intervalo data

Excel planilha formula somarproduto por intervalo data

E-mail Imprimir PDF

Saberexcel - o site das Macros Microsoft Excel VBA

Essas fórmulas com a Função SOMARPRODUTO()  do Aplicativo Microsoft Excel, somam valores baseados e um intervalo de datas, especificados em duas células (Data_Inicial) e (Data_Final), fiz também exemplo como retornar Valor Máximo(), Valor Menor(), nesse intervalo de datas. Espero que o exemplo de planilha possa lhe ajudar. Fique com Deus, Expedito Marcondes




Esse exemplo foi retirado da Coleção 15.000 macros Microsoft Excel VBA, Fórmulas e Funções


FÓRMULAS USADAS

=SOMARPRODUTO(($A$2:$A$7>=$D2)*($A$2:$A$7<=$E2)*$B$2:$B$7)
=SOMARPRODUTO(($A$2:$A$7>=$D2)*($A$2:$A$7<=$E2)*$B$2:$B$7)/(DATADIF($D2;$E2;"d")+1)

Fórmulas Matriciais
{=MÁXIMO(SE(($A$2:$A$7>=$D2)*($A$2:$A$7<=$E2);$B$2:$B$7;""))}
{=MAIOR(SE(($A$2:$A$7>=$D2)*($A$2:$A$7<=$E2);$B$2:$B$7;"");2)}
{=MAIOR(SE(($A$2:$A$7>=$D2)*($A$2:$A$7<=$E2);$B$2:$B$7;"");2)}
{=MENOR(SE(($A$2:$A$7>=$D2)*($A$2:$A$7<=$E2);$B$2:$B$7;"");2)}



Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel





  Baixe o exemplo de planilha contendo as fórmulas acima
Excel planilha formula somarproduto por intervalo data (67.79 KB)

Última atualização em Qua, 31 de Outubro de 2012 08:14  

Comentários  

 
# Andreza 10/07/2014 09:39
Gostaria de uma ajuda...
Estou fazendo uma planilha escolar e preciso obter um retorno X entre um intervalo de datas...
Exemplo...crianças nascidas entre 01/04/2014 e 31/05/2015 serão matriculadas na turma BI - as nascidas entre 01/04/13 e 31/03/2014 BII - de 01/04/2012 a 31/03/2013 MI - de 01/04/2011 a 31/03/2012 MII e de 01/04/2010 a 31/03/2011 Etapa I...o problema é que das várias formas que tentei só dá certo o primeiro retorno, os demais dão valor errado...acho que o problema é que num sei trabalhar com data...pois coloco que se a criança nascida em f4 01/12/2014 =se(f4>=01/04/2014;f4
Responder | Responder com citação | Citação
 

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4431
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana29091
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês42820
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10465649
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA