Home Excel - Formulas e Funções Excel Formulas - Data Tempo Idade Excel planilha formulas ano bissexto de uma data e concatena dados

Excel planilha formulas ano bissexto de uma data e concatena dados

E-mail Imprimir PDF

 
 Saberexcel - o site de quem precisa aprender Macros Microsoft Excel VBA

Formula verifca se o ano é bissexto e retorna verdadeiro ou falso
Saberexcel - Dicas de Fórmulas e funções

Essas fórmulas verificam se o ano de determinada data é ou não bissexto, fiz uma fórmula que concatena(&)
esses dados e retorna uma mensagem, também tem uma FC (Formatação Condicional)

Fórmula verifica se ano é bissexto ou não, retornando VERDADEIRO ou FALSO
Fórmula: '=MOD(ANO(A1);4)=0

Fórmula melhorada:
Fórmula: '=OU(MOD(ANO(I6);400)=0;E(MOD(ANO(I6);4)=0;MOD(ANO(I6);100)<>0))

Sugestão do amigo Reginaldo (Aucas Informática)
Fórmula:
'=MÊS(DATA(ANO(I6);2;29))=2 



Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel





    Baixe o exemplo da planilha excel com as fórmulas acima
Excel planilha formulas retorna ano bissexto de uma data e concatena dados (24.93 kB)

 



Compre o que deseja nas lojas submarino com garantia e segurança

Publicidade
Compre com segurança, garantia e ótimos preços
Eletrônicos - Submarino.com.br

Última atualização em Dom, 04 de Setembro de 2011 09:37  

Comentários  

 
# whenriques 11/12/2013 14:19
Beleza pessoal,
eu também precisei usar este recurso, porem precisava de um resultado numérico. Sei que existem infinitas formas de fazer, mas a que eu usei foi um teste de condição, que retornava 366 ou 365 associado às ideias que foram dadas.

=SE(MOD(ANO(A1),4)=0=VERDADEIRO,366,365)
Responder | Responder com citação | Citação
 

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4862
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana19909
mod_vvisit_counterSemana passada30982
mod_vvisit_counterEsse mês38097
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10460926
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA