Home Excel - Formulas e Funções Excel Formulas - Textos e Numeros Excel planilhas formulas txtnum conta ocorrencia de numeros ou itens criterios

Excel planilhas formulas txtnum conta ocorrencia de numeros ou itens criterios

E-mail Imprimir PDF

 
Contando ocorrência de números e ou ítens e retorno baseados em critérios
Saberexcel - Dicas Formulas Textos e Números

Essas fórmula do excel abaixo contam ocorrências de determinados ítens baseados em
dois critérios como mostram as fórmulas abaixo.


Retornam todos os números e ou itens baseados nos critérios.
Formula: =SOMARPRODUTO((A1:A20>5)*(A1:A20<16))
Ou
Formula: =SOMARPRODUTO(--(A1:A20>5);--(A1:A20<16))

Ou poderá usar uma formula matricial usando um Função SOMA
Para inserir uma fórmula Array(matricial)
Você deverá pressionar as teclas Ctrl, Shift e Enter

{=SOMA((A1:A20>5)*(A1:A20<16))}


Contando 'somando' números que combinam com algum dos critérios desejados
observe que aparece outra fórmula matricial, Você deverá pressionar as teclas Ctrl, Shift e Enter

{=SOMA((A1:A20=5)+(A1:A20>16)+(A1:A20=18))}

ou você poderá obter o retorno desejado sem a fórmula matricial usando a Função Cont.Se
=CONT.SE(A1:A20;"=5")+CONT.SE(A1:A20;">16")+ CONT.SE(A1:A20;"=18")

ou também poderá usar a Função Somaproduto
=SOMARPRODUTO((A1:A20=5)+(A1:A20>16)+(A1:A20=18))



Retornando número procurados por todos os critérios.
Lembre-se que para inserir uma formula matricial (representada por esses parentes)-T
Tecle Ctrl + Shift + Enter - isso insere a fórmula matricial automaticamente

Fórmula: =SOMARPRODUTO((A1:A10>3)*(A1:A10<6);A1:A10)
ou
Fórmula: =SOMARPRODUTO(--(A1:A10>3);--(A1:A10<6);A1:A10)

ou usar uma Fórmula Matricial usando a FUNÇÃO SOMA
Fórmula :
{=SOMA((A1:A10>3)*(A1:A10<6)*A1:A10)}

ou usar Fórmula matricial com as Funções SOMA() com a Função SE()
Fórmula :
{=SOMA(SE(A1:A10>3;SE(A1:A10<6;A1:A10)))}


Retornando os todos o números baseados em dois critérios
Usando a Função SOMARPRODUTO()
Fórmula :
=SOMARPRODUTO((A1:A10>3)+(A1:A10<6);A1:A10)

ou poderá usar a Função SOMASE()
Fórmula: =SOMASE(A1:A10;">3")+SOMASE(A1:A10;"<6")


Aprenda tudo sobre o Aplicativo Microsoft Excel VBA com SaberExcel







Compras com segurança na internet Lojas SubMarino

Última atualização em Dom, 18 de Setembro de 2011 17:35  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje5095
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana29755
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês43484
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10466313
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA