Home Excel - Formulas e Funções Excel Formulas - Textos e Numeros Excel planilhas formulas txtnum retorna maiores valores em range

Excel planilhas formulas txtnum retorna maiores valores em range

E-mail Imprimir PDF

   Saberexcel - Site das macros

                                                                                                                                                                      tudosobreexcel
Fórmula do Aplicativo Microsoft Excel retorna o maior número

Retorna o maior número
Fórmula usada.......: {=MAIOR(A1:A10;{1;2;3})}
Tipo de fórmula....: = Matricial

ou

Fórmula usada....: = {=MAIOR(A1:A10;LIN(INDIRETO("1:3")))}
Tipo de fórmula....: = Matricial

Para inserir uma formula matricial, selecione a célula com o mouse,em seguida tecle (Ctrl+Shift+Enter)
Fórmula usada.......: =MÁXIMO(A1:A10)
Fórmula usada.......: =SE(CONT.SE($A$1:$A$10;"<"&B1)=0;"";MAIOR($A$1:$A$10;CONT.SE($A$1:$A$10;">="&B1)+1))

Retorna o maior número na coluna B usando critério
Fórmula usada.......: {=MAIOR(SE(A1:A10>=A1;B1:B10;"");{1;2;3})}
Tipo de fórmula....: = Matricial

ou

Fórmula usada.......: {=MAIOR(SE(A1:A10>=A1;B1:B10;"");LIN(INDIRETO("1:3")))}
Tipo de fórmula....: = Matricial


Maior número na coluna(A)
Fórmula usada.......: {=MAIOR(A:A;LIN(INDIRETO("1:"&CONT.VALORES(A:A))))}
Tipo de fórmula....: = Matricial


Trabalhando com critérios, a acima mencionada fórmula deve ser modificada como isto (ele realmente não trabalhará com colunas inteiras, mas você pode omitir somente a linha superior)

Fórmula usada.......: {=MAIOR(SE(A2:A65536=A2;B2:B65536;"");LIN(INDIRETO("1:"&CONT.VALORES(A:A))))}
Tipo de fórmula....: = Matricial




Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com os produtos didaticos SaberExcel



   Baixe o exemplo de planilha das fórmulas acima:
Excel formulas txtnum retorna maiores valores em range (10.81 kB 2010-12-09 07:42:05)

Última atualização em Dom, 18 de Setembro de 2011 17:47  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4960
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana24466
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês38195
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10461024
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA