Home Excel - Formulas e Funções Excel Formulas - Textos e Numeros Excel planilhas formulas txtnum retorna ultima palavra digitada

Excel planilhas formulas txtnum retorna ultima palavra digitada

E-mail Imprimir PDF

Saberexcel - O Site das Macros

Retorna última palavra digitada.
Saberexcel - dicas de fórmulas e funções

Fórmula do Aplicativo Microsoft Excel retorna a última palavra digitada na célula(A1), com critério na célula(B1), observem que busca a última palavra digitada depois de um espaço.

Fórmula digitada:

FÓRMULA RETORNA O ÚLTIMO NÚMERO DIGITADO(criterio B1)

'=SE(B1="";"";SE(B1>NÚM.CARACT(A1)-NÚM.CARACT(SUBSTITUIR(A1;" ";""));DIREITA(A1;NÚM.CARACT(A1)-LOCALIZAR("^^";SUBSTITUIR(A1;" ";"^^";NÚM.CARACT(A1)-NÚM.CARACT(SUBSTITUIR(A1;" ";"")))));SE(B1=1;MID(A1;1;LOCALIZAR("^^";SUBSTITUIR(A1;" ";"^^";1))-1);EXT.TEXTO(A1;LOCALIZAR("^^";SUBSTITUIR(A1;" ";"^^";B1-1))+1;LOCALIZAR("^^";SUBSTITUIR(A1;" ";"^^";B1))-LOCALIZAR("^^";SUBSTITUIR(A1;" ";"^^";B1-1))-1))))




Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com os produtos didaticos SaberExcel




  Baixe o exemplo da fórmula acima


Última atualização em Dom, 28 de Outubro de 2012 07:09  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4932
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana19979
mod_vvisit_counterSemana passada30982
mod_vvisit_counterEsse mês38167
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10460996
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA