Home Excel - Formulas e Funções Excel Formulas - Textos e Numeros Excel planilhas formulas txtnum retorna primeira palavra nome

Excel planilhas formulas txtnum retorna primeira palavra nome

E-mail Imprimir PDF

  Saberexcel - O Site das Macros

Retorna a primeira palavra digitada de uma determinada célula.
Saberexcel - dicas de fórmulas e funções

Fórmula do Aplicativo Microsoft Excel retorna a primeira palavra digitada na célula(A1), com critério na célula(B1), observem que busca a primeira digitada depois de um espaço, se usarmos a primeira fórmula para busca , em uma célula que contiver apenas um nome, retornará um erro #VALOR
pois a fórmula busca o proxima palavra depois do último "espaço", porém a segunda fórmula trata esse tipo de erro.

Fórmula usada: =ESQUERDA(A1;LOCALIZAR(" ";A1)-1)

Observe que a mesma fórmula poderá retornar um erro se não houver um espaço e mais uma palavra.
Essa fórmulas abaixo mostra como fazer um tratamento de erro,
mesmo que não houver espaço, não ocorre erro, como no exemplo acima


Fórmula usada: =SE(ÉERROS(LOCALIZAR(" ";A1)-1);A1;ESQUERDA(A1;LOCALIZAR(" ";A1)-1))

Fórmula usada: =SE(ÉERROS(LOCALIZAR(" ";A2)-1);A2;ESQUERDA(A2;LOCALIZAR(" ";A2)-1)) 




Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com os produtos didaticos SaberExcel





  Baixe o exemplo de planilha das fórmula acima
Excel formulas txtnum retorna primeira palavra nome (11.33 kB 2010-12-08 16:52:48)

Última atualização em Dom, 18 de Setembro de 2011 17:56  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje5088
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana29748
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês43477
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10466306
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA