Home Excel - Formulas e Funções Excel Formulas - Textos e Numeros Excel planilhas formulas txtnum retorna palavra meio do nome

Excel planilhas formulas txtnum retorna palavra meio do nome

E-mail Imprimir PDF

 Saberexcel - O Site das macros

Fórmula do Aplicativo Microsoft Excel retorna a palavra do meio
Saberexcel - dicas de formulas e funções

Retorna o nome do meio
Exemplo(I):
Celula(A1) ..........: = Saberexcel Site das Macros
Celula(A1) ..........: = ARRUMAR(EXT.TEXTO(A1;LOCALIZAR(" ";A1);LOCALIZAR(" ";A1;LOCALIZAR(" ";A1)+1)-LOCALIZAR(" ";A1)))
Retorno ...........: = Site

Retorna o espaço em branco
Observe que na célula (A2) não há o nome do meio, para isso teria que haver um terceiro
nome,não havendo a fórmula retorna o espaço em branco (digite apenas uma palavra e de um espaço)

Exemplo(II):
Celula(A2) ..........: Saberexcel (Palavra mais espaço - sem espaço retorna um erro)
Fórmula Usada.....: =SE(NÚM.CARACT(A3)-NÚM.CARACT(SUBSTITUIR(A3;" ";""))=1;"";ARRUMAR(EXT.TEXTO(A3;LOCALIZAR(" ";A3);LOCALIZAR(" ";A3;LOCALIZAR(" ";A3)+1)-LOCALIZAR(" ";A3))))
Retorno ...........: (em branco - pois vai retornar o espaço em branco)



ou poderá usar essa outra fórmula
Exemplo(III):
Celula(A1) ..........: Saberexcel Site das Macros
Fórmula Usada.....: =SE((ÉERRO(PROCURAR(" ";SUBSTITUIR(A1;" ";"";1))));"";ESQUERDA(MUDAR(A1;1;PROCURAR(" ";A1);"");PROCURAR(" ";MUDAR(A1;1;PROCURAR(" ";A1);""))))
Retorno ...........: = Site 



   Baixe o exemplo de planilha referente as fórmulas acima:
Excel formulas txtnum retorna palavra meio do nome (11.53 kB 2010-12-08 16:44:20)

Última atualização em Dom, 28 de Outubro de 2012 07:23  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje3892
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana23398
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês37127
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10459956
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA