Home Excel - Formulas e Funções Excel Formulas - Referencias Excel planilhas formula indice corresp duplicados

Excel planilhas formula indice corresp duplicados

E-mail Imprimir PDF

Saberexcel - o site de quem precisa Aprender Macros Microsoft Excel VBA

Esse exemplo do uso de funções do Aplicativo Microsoft Excel, Função Corresp(), Funçao Desloc() e outras
mostra os dados duplicados e também não duplicados em ordem crescente baseado no preço.
filtrando por dois critérios.

(*) baixe o exemplo de planilha no final da página para visualizar as fórmulas usadas nas tabelas.

Algumas das fórmulas matriciais usadas no retorno dos dados desejados nas tres tabelas existentes na folha de planilha exemplo.
Aconselho baixar o exemplo para visualizar melhor a aplicação de distribuição das fórmulas com as referidas funções pela folha de planilha.

Fórmulas usadas......:      =SE(ÉNÚM(J4);ÍNDICE($A$3:$A$30;CORRESP(J4;$C$3:$C$30;0));"")
Fórmulas usadas......:      =MENOR(SE($B$3:$B$30=$G$1;SE($E$3:$E$30=$G$2;$C$3:$C$30));LINS(J$3:J3))
Fórmulas usadas .....:      =ÍNDICE($D$3:$D$30;CORRESP(J3;$C$3:$C$30;0))
Fórmulas usadas .....:      =ÍNDICE($A$3:$A$30;CORRESP(M7;$C$3:$C$30+LIN($C$3:$C$30)/9^9;0))
Fórmulas usadas .....:      =SE(SOMA(($B$3:$B$30=$G$1)*($E$3:$E$30=$G$2))<LINS(P$3:P7);"";MENOR(SE($B$3:$B$30=$G$1;
                                     SE
($E$3:$E$30=$G$2;$C$3:$C$30+LIN($C$3:$C$30)/9^9));LINS(P$3:P7)))





Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel




   Baixe o exemplo de planilha contendo as fórmulas acima
Excel formulas indice duplicados e nao duplicados (14.48 KB)


Publicidade
Compre com segurança, garantia e ótimos preços
Eletrônicos - Submarino.com.br

Última atualização em Dom, 18 de Setembro de 2011 16:54  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4812
mod_vvisit_counterOntem4316
mod_vvisit_counterEsta Semana19259
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês32988
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10455817
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA