Home Excel - Formulas e Funções Excel Formulas - Referencias Excel planilhas formulas procv desloc corresp busca correspondente_II

Excel planilhas formulas procv desloc corresp busca correspondente_II

E-mail Imprimir PDF

Saberexcel - o site de quem precisa aprender macros Microsoft Excel VBA.

Exemplo do uso da Função do Aplicativo Microsoft Excel,  Indice() + Corresp() + Maior(), usado para retorno de determinado ítem baseado em critério de valores dependendo do valor. Para esse criar os critérios valores ascendentes foram usados a
Função Maior() + Lin().
Também poderia fazer em ordem ascentendente usando a Função Mín(), nos critérios.
Espero que o exemplo possa ajudá-los. Fique com Deus - Expedito Marcondes. 
'foi colocado como II no título para ajudar a identificar os exemplos Ok...

Cidade Valor 
  
São Paulo          R$ 20.000,00
   
Campinas           R$ 40.000,00    
Ribeirão Preto    R$ 10.000,00    
Ituverava          R$ 15.000,00    
    
Primeiro:    Campinas           =ÍNDICE($A$3:$A$6;CORRESP(D8;$B$3:$B$6;0))  R$ 40.000,00  =MAIOR($B$3:$B$6;LIN()-7)
Segundo:  São Paulo           =ÍNDICE($A$3:$A$6;CORRESP(D9;$B$3:$B$6;0))  R$ 20.000,00  =MAIOR($B$3:$B$6;LIN()-7)
Terceiro:   Ituverava            =ÍNDICE($A$3:$A$6;CORRESP(D10;$B$3:$B$6;0))  R$ 15.000,00  =MAIOR($B$3:$B$6;LIN()-7)
Quarto:     Ribeirão Preto     =ÍNDICE($A$3:$A$6;CORRESP(D11;$B$3:$B$6;0))  R$ 10.000,00  =MAIOR($B$3:$B$6;LIN()-7)




Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel




   Baixe o exemplo de planilha contendo as funções acima.
Excel formulas procv desloc corresp busca correspondente_II (59.13 KB)



Publicidade
Compre com segurança, garantia e ótimos preços
Eletrônicos - Submarino.com.br

Última atualização em Dom, 18 de Setembro de 2011 16:55  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje588
mod_vvisit_counterOntem4798
mod_vvisit_counterEsta Semana32643
mod_vvisit_counterSemana passada39550
mod_vvisit_counterEsse mês9885
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10432714
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA