Home Excel - Formulas e Funções Excel Formulas - Referencias Excel planilhas formulas ref busca valores coluna retorna criterio

Excel planilhas formulas ref busca valores coluna retorna criterio

E-mail Imprimir PDF

Saberexcel - o site de quem precisa Aprender Microsoft Excel VBA

Fórmulas buscam determinado valores em coluna baseada em criterio
Saberexcel - dicas de fórmulas e funções

Fórmulas do aplicativo Microsoft Excel retornam buscas a determinados dados utilizando as funções
Indice(), Proc(), Corresp() É.NAO.VAZIA(),


Esta fórmula mostra último número digitado,
Veja bem, se você vem digitando, A1, A2, A3, a fórmula retornará o útimo número,
pois a fórmula basea-se em um índice, se você deletar a primeira célula, observe
que o retorno é o segundo número debaixo para cima. 


Busca pela letra do alfabeto na coluna[C]

Retorna o último ítem(texto) da coluna (A)

RETORNAR PALAVRA(TEXTO) NA COLUNA(A), OBSERVAR RESULTADO DA FÓRMULA
Formula Usada .........:    =ÍNDICE(A:A;CONT.VALORES(A:A))      
    
Retorna o último ítem(texto) da coluna (A)    
Formula Usada .........:   =ÍNDICE(A:A;CORRESP(REPT("z";255);A:A))      
    
Fórmula trabalha com linhas e não com colunas, para retornar valores com colunas mude a fórmula
Fórmula usada........: {=ÍNDICE(A1:A101;MÁXIMO(NÃO(ÉCÉL.VAZIA(A1:A101))*LIN(A1:A101)))}
(*) Bom lembrar que para trabalhar com fórmula matricial, selecione sua fórmula e tecle (Ctrl + Shit + Enter)
Retorna o último ítem(Texto) da coluna (A)    
Formula Usada .........:    =ÍNDICE(A1:A101;MÁXIMO(NÃO(ÉCÉL.VAZIA(A1:A101))*LIN(A1:A101)))  

PARA RETORNAR NÚMEROS        
Retorna o ultimo texto digitado na coluna [C] 
Formula Usada .........:    =PROC(REPT("z";255);C:C)  
    
    
Retorna o último número digitado coluna(A)    
Formula Usada .........:    =ÍNDICE(A:A;CORRESP(9,99999999999999E+307;A:A))  
    
    
PARA RETORNAR TEXTO OU FÓRMULAS
Retorna o número da linha ativa    
Formula Usada .........:    =SE(A13="";"";LIN())  
    
    
Retorna o valor máximo intervalo duas colunas  
Formula Usada .........:    =ÍNDICE(C:C;MÁXIMO(D:D))  
    
    
Retorna o valor baseado números coluna(B)   
Formula Usada .........:    =ÍNDICE(A:A;MÁXIMO(B:B))




Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel







 
 baixe o exemplo de planilha contendo as fórmulas acima.






Publicidade
Compre com segurança, garantia e ótimos preços
Eletrônicos - Submarino.com.br

Última atualização em Dom, 18 de Setembro de 2011 17:05  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje911
mod_vvisit_counterOntem5104
mod_vvisit_counterEsta Semana30675
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês44404
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10467233
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA