Home Excel - Formulas e Funções Excel Formulas - Referencias Excel funcao modo retorna numero maior ocorrencia range

Excel funcao modo retorna numero maior ocorrencia range

E-mail Imprimir PDF

Saberexcel - Dicas de Fórmulas e Funções

Usando critérios multiplos para busca de determinados números

Essas fórmulas do Aplicativo Microsoft Excel, retornam determinado dado, baseado em uma busca em critérios múltiplos,


Quando você digitar os critérios "Nome" na Célula(D1) e SobreNome na Célula(E1)
Vai retornar a idade:

Primeiro nome na...........: Coluna(A)
Sobrenome na..............: Coluna(B)
Idade na coluna.............: Coluna(C)

Critérios
Primeiro Nome na...........: Célula(D1)
Ultimo nome na .............: Célula(E1)


Fórmula usada....: {=SOMARPRODUTO((A1:A1001=D1)*(B1:B1001=E1)*(C1:C1001))}
Retorna .........: "Idade que esta na célula(C1) baseados nos nomes e sobrenomes que estão células($D$1)e ($C$1 )

Concatenando dados para uma mensagem..:
Mensagem correta....: Lucia [ Ferrarini ] sobrenome correto, tem [ 35 ] Anos de idade
Mensagem #Erro#....: Sobrenome de: [ Lucia ] não é : [ Menezes ] esta errado!

Formula usada....:
=SE(I16=0;"Sobrenome de: [ "&D1&" ] não é : [ "&E1&" ] esta errado!";D1&" [ "&E1&" ] sobrenome correto, tem [ "&I16&" ] Anos de idade"

ou

Formula usada....: {=SOMA((A1:A1002=D1)*(B1:B1002=E1)*C1:C1002)}
Retorna............: idade (35)

ou poderá também usar essa fórmula

Formula usada....: {=SOMA(SE(A1:A1002=D1;SE(B1:B1002=E1;C1:C1002)))}

usando a função ìndice e corresp

Formula usada....: {=ÍNDICE(C1:C1002;CORRESP(1;(A1:A1002=D1)*(B1:B1002=E1);0))} 




Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel

 

 

 



Publicidade
Compre com segurança, garantia e ótimos preços
Eletrônicos - Submarino.com.br

Última atualização em Ter, 16 de Agosto de 2011 20:06  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4867
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana25068
mod_vvisit_counterSemana passada30982
mod_vvisit_counterEsse mês43256
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10466085
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA