Home Excel - Formulas e Funções Excel Formulas - Referencias Excel planiha formula subtotal conta valores

Excel planiha formula subtotal conta valores

E-mail Imprimir PDF

Escola Saberexcel VBA Estudos - Treinamento com Macros, Fórmulase Funções

Essa fórmula do Aplicativo Microsof Excel com auxilio da função ECEL.VAZIA, SUBTOTAL E DESLOC,    
cont.valores usando a função subtotal deslocando dados abaixo. baixe o exemplo de planilha no final da página
    
    
11  =SE(ÉCÉL.VAZIA($B12);"";SUBTOTAL(3;DESLOC($B$1;0;0;LIN()))-1)  
    
cont.valores usando a função subtotal deslocando dados abaixo    
    
    
fórmula usada     
'=SE(ÉCÉL.VAZIA($B12);"";SUBTOTAL(3;DESLOC($B$1;0;0;LIN()))-1)    


'- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
sobre a função subtotal

SUBTOTAL (Função SUBTOTAL)
Este artigo descreve a sintaxe da fórmula e o uso da função (função: um fórmula pré-desenvolvida que assume um valor ou vários valores, executa uma operação e retorna um valor ou vários valores. Use as funções para simplificar e reduzir fórmulas em uma planilha, especialmente aquelas que executam cálculos longos e complexos.) SUBTOTAL no Microsoft Excel.

Descrição

Retorna um subtotal em uma lista ou em um banco de dados. É geralmente mais fácil criar uma lista com subtotais usando o comando Subtotais, grupo Contorno, na guia Dados no aplicativo de desktop do Excel. Assim que a lista de subtotais for criada, você poderá modificá-la editando a função SUBTOTAL.

Sintaxe

SUBTOTAL(núm_função,ref1,[ref2],...])

A sintaxe da função SUBTOTAL tem os seguintes argumentos
(argumento: um valor que fornece informações a uma ação, um evento, um método, uma função ou um procedimento.):

  • Núm_função     Obrigatório. O número de 1 a 11 (incluindo valores ocultos) ou 101 a 111 (ignorando valores ocultos) que especifica qual função usar no cálculo de subtotais dentro de uma lista.

Núm_função
(incluindo valores ocultos)

Núm_função
(ignorando valores ocultos)

Função

1

101

MÉDIA

2

102

CONTA

3

103

CONT.VALORES

4

104

MÁX

5

105

MÍN

6

106

MULT

7

107

DESVPAD

8

108

DESVPADP

9

109

SOMA

10

110

VAR

11

111

VARP

  • Ref1     Obrigatório. O primeiro intervalo nomeado ou referência cujo subtotal você deseja.
  • Ref2,...     Opcional. Intervalos nomeados ou referências de 2 a 254 cujo subtotal você deseja.

Comentários

  • Se existirem outros subtotais dentro de ref1; ref2,… (ou subtotais aninhados), esses subtotais aninhados serão ignorados para evitar dupla contagem.
  • Para as constantes núm_função de 1 a 11, a função SUBTOTAL inclui os valores de linhas ocultas pelo comando Ocultar Linhas no submenu Ocultar e Exibir do comando Formato no grupo Células, na guia Página Inicial no aplicativo de desktop do Excel. Use essas constantes para subtotalizar números ocultos e não ocultos em uma lista. Para as constantes núm_função de 101 a 111, a função SUBTOTAL ignora valores de linhas ocultos pelo comando Ocultar Linhas. Use essas constantes para subtotalizar somente números não ocultos em uma lista.
  • A função SUBTOTAL ignora as linhas não incluídas no resultado de um filtro, independentemente de qual valor de núm_função seja utilizado.
  • A função SUBTOTAL foi projetada para colunas de dados ou intervalos verticais. Ela não foi projetada para linhas de dados nem intervalos horizontais. Por exemplo, quando você subtotaliza um intervalo horizontal usando uma núm_função de 101 ou maior, como SUBTOTAL(109,B2:G2), ocultar uma coluna não afeta o subtotal. Porém, ocultar uma linha em um subtotal de um intervalo vertical afeta o subtotal.
  • Se qualquer uma das referências for uma referência 3D, a função SUBTOTAL retornará o valor de erro #VALOR!.



    Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Escola Saberexcel VBA Estudos® - Treinamentos com Macros, Fórmulas e Funções.





        baixe o exemplo de planilha contendo a fórmula acima
    Excel planilha formula subtotal conta valores (14.03 KB)
Última atualização em Ter, 24 de Janeiro de 2012 13:25  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4915
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana19962
mod_vvisit_counterSemana passada30982
mod_vvisit_counterEsse mês38150
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10460979
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA