Home Excel - Formulas e Funções Excel Formulas - Referencias Excel formulas matriciais extraindo dados ordem

Excel formulas matriciais extraindo dados ordem

E-mail Imprimir PDF


Saberexcel - O site de quem precisa aprender sobre Macros Microsoft Excel VBA

Essas fórmulas matriciais do aplicativo Microsost Excel, filtra valores e ordena conforme desejado.

1 - duplicados referente a determinadas datas(anos), também valores
2 - sem formatos de duplicados na ordem crescrescente.
3 - somente os 10 na ordem crescente.
4 - Formatação condicional referente aos anos

Formulas matriciais usadas

Formatando valores Duplicados:

Fórmula usada:
SE(I3="";"";ÍNDICE($A$3:$A$30;CORRESP(I3;$C$3:$C$30;0)))
Formatação Condicional usada:
'----------------------'
Formula Matricial:
'{=SE(CONT.SE($B$3:$B$30;$F$1)<LINS(I$3:I3);"";MENOR(SE($B$3:$B$30=$F$1;$C$3:$C$30);LINS(I$3:I3)))}
'=SE(I3="";"";ÍNDICE($D$3:$D$30;CORRESP(I3;$C$3:$C$30;0)))
'----------------------'
Formula Matricial:
{=SE($M3="";"";ÍNDICE($A$3:$A$30;CORRESP(M3;$C$3:$C$30+LIN($C$3:$C$30)/9^9;0)))}
'----------------------'
{=SE(CONT.SE($B$3:$B$30;$F$1)<LINS(M$3:M3);"";MENOR(SE($B$3:$B$30=$F$1;$C$3:$C$30+LIN($C$3:$C$30)/9^9);LINS(M$3:M3)))}
'----------------------'
{=SE(M3="";"";ÍNDICE($D$3:$D$30;CORRESP(M3;$C$3:$C$30+LIN($C$3:$C$30)/9^9;0)))}
'----------------------'
somente os 10 Primeiros
{=ÍNDICE($A$3:$A$30;CORRESP(Q3;$C$3:$C$30+LIN($C$3:$C$30)/9^9;0))}
{=MENOR(SE($B$3:$B$30=$F$1;$C$3:$C$30+LIN($C$3:$C$30)/9^9);LINS(Q$3:Q3))}
{=SE(Q3="";"";ÍNDICE($D$3:$D$30;CORRESP(Q3;$C$3:$C$30+LIN($C$3:$C$30)/9^9;0)))}
{=SE(Q3="";"";ÍNDICE($D$3:$D$30;CORRESP(Q3;$C$3:$C$30+LIN($C$3:$C$30)/9^9;0)))}



Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Escola Saberexcel VBA Estudos® - Treinamentos com Macros, Fórmulas e Funções



  Baixe o exemplo de Planiha contendo as Fórmulas acima:
Excel formulas matriciais extrair dados ordem (22.5 KB)

Última atualização em Ter, 25 de Outubro de 2011 18:17  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4864
mod_vvisit_counterOntem4316
mod_vvisit_counterEsta Semana19311
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês33040
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10455869
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA