Home Excel - Formulas e Funções Excel Formulas - Formatacao Condicional Excel fc formatacao condicional varias fórmulas

Excel fc formatacao condicional varias fórmulas

E-mail Imprimir PDF

Saberexcel - o site das macros

Excel VBA Macros - macros e fórmula do aplicativo microsoft excel insere uma formatação condicional quadriculada
FC - Formatação Condicional Fórmulas Excel -  Esta fórmula insere uma formatação condicional quadriculada
Selecionar a área e inserir a fórmula

veja nossos módulos COMO FAZER - Formatação Condicional com macros e fórmulas - (excelentes exemplos de planilhas)

'=MOD(LIN();3)=MOD(COL();3)

Site das Macros Excel VBA
(15.000 Macros, Funções, Fórmulas, Blog, Apostilas, Dicas, Boletins, 14.000 Planilhas Modelos)
http://www.saberexcel.com/
'……………………………'
Expedito Marcondes
VBA Excel - Insere formatação condicional nas células Planilhas Excel
Formatação Condicional

VBA Excel Planilhas -  Esta macro insere formatação condicional nas células
'selecionada e inseridas esta macro
'para facilitar vou colocar a seleção range("A1:K15")
'A formata com a cor laranja
'B formata na cor roxo
'C azul


Sub Inserir_formatacao_condicional()
Range("a1:K15").Select
Selection.FormatConditions.Delete
Selection.FormatConditions.Add Type:=xlCellValue, Operator:=xlEqual, Formula1:="=""A"""
Selection.FormatConditions(1).Font.ColorIndex = xlAutomatic
Selection.FormatConditions(1).Interior.ColorIndex = 4
Selection.FormatConditions.Add Type:=xlCellValue, Operator:=xlEqual, Formula1:="=""B"""
Selection.FormatConditions(2).Font.ColorIndex = xlAutomatic
Selection.FormatConditions(2).Interior.ColorIndex = 7
Selection.FormatConditions.Add Type:=xlCellValue, Operator:=xlEqual, Formula1:="=""C"""
Selection.FormatConditions(3).Font.ColorIndex = xlAutomatic
Selection.FormatConditions(3).Interior.ColorIndex = 8
 
End Sub

Procedimentos do microsoft excel vba verifica se existe ou não Formatação Condicional
Formatação Condicional  » Excel  VBA - Este procedimento e para ver ser existe ou não formação condicional
inserir no módulo Worksheet

Private Sub Worksheet_SelectionChange(ByVal Target As Excel.Range)
    If HasCondFormat(ActiveCell) Then
     MsgBox ActiveCell.Address & " existe formato condicional nesta planilha."
    End If

End Sub

 

E. Marcondes 
Excel VBA - Formatação condicional (fórmulas) Planilhas Excel
Formatação Condicional No Comments »Formatação condicional  (fórmulas)

=E(CONT.NÚM(A2)=1;A2=0)
=E(A2=0;NÃO(ÉCÉL.VAZIA(A2)))
=E(A2=0;NÚM.CARACT(A2)>0)
=NÃO(ÉCÉL.VAZIA(A2))*(A2=0)
'——————————————————’
'Pode-se usar formatação condicional, nos dados da coluna, com a seguinte fórmula:
=É.NÃO.DISP(PROCH(A2;$A$1:$T$1;1;0))=FALSO
'——————————————————’
Hoje com três formatações
 
primeira formatação
=<HOJE()
 
Segunda Formatação
=<HOJE()+2*7
 
Terceira Formatação
<=HOJE()+12*7
'——————————————–'
FORMATAÇÃO CONDICIONAL
 
=NÃO(ÉCEL.VAZIA(células))
=E(A1<>”";É.NÃO.DISP(PROCV(A1;$B:$B;1;0)))
'———————————————'
Condição 1 :                 =SE(CONT.SE($A:$A;A1)>=1;SE(CONT.SE(B:B;A1)=0;1;0)) >> vermelho
Condição 2 :                 =SE(CONT.SE($A:$B;A1)>1;1;0) >> verde
'—————————————————————————'
Condição1, A formula : =OU(A1=data) formata verde
Condição2, A fórmula : =OU(A1<>data) formata vermelho
'—————————————————————————'
Condição1, A formula :  =OU(EXACT(A1;Col2))  formata cor cinza
Condição2, A formula:  =OU(A1<>Col2) formata verde ou cinza
'—————————————————————————'
Condição1, A formula : =OU(EXACT(A1;Col2))
Condição2, A formula:  =OU(A1<>Col2)  formata a cor verde
'————————————————————————-'
insere formatação condic:    '=$A1>HOJE()      
insere formatação condic:    '=SE($K5>5500;VERDADEIRO;FALSO)
           
 Inserir fórmula na célula D5    ( Célula b5 inserir Data )
=SE(B5="";"";SE(DATA(ANO(B5);MÊS(B5)+1;0)=B5;"";B5+1))

'numero da semana na célula A6 
=SE(B6="";"";INT((B6-(DATA(ANO(B6+(MOD(8-DIA.DA.SEMANA(B6);7)-3));1;1))-3+MOD(DIA.DA.SEMANA(DATA(ANO(B6+(MOD(8-DIA.DA.SEMANA(B6);7)-3));1;1))+1;7))/7)+1) 

 

formatação condicional formata todos os sábados e domingos de um calendário
=OU(DIA.DA.SEMANA(C7)=1;DIA.DA.SEMANA(C7)=7)



Última atualização em Dom, 21 de Outubro de 2012 15:25  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4956
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana24462
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês38191
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10461020
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA