Home Excel - Formulas e Funções Excel Formulas - Data Tempo Idade Excel planilhas formulas contando semanas no mes

Excel planilhas formulas contando semanas no mes

E-mail Imprimir PDF

 Saberexcel - o site de quem precisa aprender Microsoft Excel VBA


Contando semanas usando Fórmulas
Saberexcel - Dicas de Fórmulas e Funções

Esta formula calcula quantas semanas faltam para terminar o mês a partir da data
Digita na uma data desejada na célula(A1)

Obtendo uma reposta concatenando dado:
Até a presente data 01/09/2010 faltam 5 semanas para terminar o mês de setembro 2010
5 semanas para terminar o mês de setembro 2010

Fórmula Usada
="Até a presente data "&TEXTO(A1;"dd/mm/aaaa")&" faltam "&INT((DATA(ANO(HOJE());MÊS(HOJE())+1;0)-DATA(ANO(HOJE());MÊS(HOJE());DIA(A1)))/7+1)&" semanas para terminar o mês de "&TEXTO(A1;"mmmm")&" "&TEXTO(A1;"aaaa")


=INT((DATA(ANO(HOJE());MÊS(HOJE())+1;0)-DATA(ANO(HOJE());MÊS(HOJE());DIA(A1)))/7+1) &" semanas para terminar o mês de "&TEXTO(A1;"mmmm")&" "&TEXTO(A1;"aaaa")

Contando semanas entre duas datas baseado no dia da semana da célula(A1)
Neste intervalo de datas: [01-setembro-2010 e 09-outubro-2010]
5 Semanas

Formulas usadas
="Neste intervalo de datas: ["&TEXTO(A1;"dd-mmmm-aaaa")&" e "&TEXTO(B1;"dd-mmmm-aaaa"&"]")
=SOMARPRODUTO(--(DIA.DA.SEMANA(LIN(INDIRETO(A1&":"&B1));1)=C1))& " Semanas"

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA com SaberExcel



   Baixe o exemplo de planilha contendo as fórmulas acima
Excel planilhas formulas contando semanas no mes (12.24 kB)







Produtos de beleza e saúde a bons preços com a confiança das Lojas submarino

Beleza & Saúde - Submarino.com.br

Última atualização em Dom, 04 de Setembro de 2011 09:22  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4952
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana24458
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês38187
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10461016
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA