Home Excel - Formulas e Funções Excel Formulas - Data Tempo Idade Excel planilhas formulas datas funcao edate acrescenta meses a uma data

Excel planilhas formulas datas funcao edate acrescenta meses a uma data

E-mail Imprimir PDF

 
Formula alternativa a (EDATE) para adiciona meses a uma data


Saberexcel - o site de quem precisa Aprender Macros Microsoft Excel VBA

Esta é uma alternativa de fórmulas para o Aplicativo Microsoft Excel, para quem não quiser instalar suplementos de Ferramentas de Análise no seu Aplicativo Micorosoft.

Então, é uma alternativa para fórmula (EDATE), voce consegue inserindo suplementos do Aplicativo Microsoft Excel

C3 = '=SE(DIA(A1)<>DIA(DATA(ANO(A1);MÊS(A1)+B1;DIA(A1)));DATA(ANO(A1);MÊS(A1)+B1+1;0);DATA(ANO(A1);MÊS(A1)+B1;DIA(A1)))

B1 = Acrescenta os meses na data gerando uma nova data acrescentada dos meses

Exemplo:

A1 = Hoje() 'retorna data de Hoje
B1 = 10 'total de meses a ser acrescentado a nova data
C3 = Resultado ' insira a fórmula acima nesta célula para obtenção do resultado Acrescido dos meses(B1)



Esta fórmula evita problemas com números diferentes de dias um mês.
Ela retornará o mesmo valor da fórmula acima, acrescida do total de meses inseridos na célula(B1), calculando também o final do mês,
não ocorrendo o risco de sobreposição no mes imediatamente seguinte.
com esta fórmula voce também evita de instalar o suplemento de ferramentas para acessar a Função EDATE
'=DATA(ANO(A1);MÊS(A1)+B1;MÍNIMO(DIA(A1);DIA(DATA(ANO(A1);MÊS(A1)+B1+1;0))))




Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel





    Baixe o exemplo das fórmulas no Aplicativo Microsoft Excel

Excel formulas datas funcao edate acrescenta meses a uma data (12.22)



Compre Notebooks e outros com segurança e garantia pelas Lojas Submarino, ótimos preços

Última atualização em Dom, 21 de Outubro de 2012 09:59  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4874
mod_vvisit_counterOntem5059
mod_vvisit_counterEsta Semana19921
mod_vvisit_counterSemana passada30982
mod_vvisit_counterEsse mês38109
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10460938
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA