Home Excel - Formulas e Funções Excel Formulas - Data Tempo Idade Excel planilha formulas evite fins de semana sabado e domingo no embarque

Excel planilha formulas evite fins de semana sabado e domingo no embarque

E-mail Imprimir PDF

Saberexcel - o site de quem precisa Aprender Macros Microsoft Excel VBA
Fórmula sugere o dia útil mais proximo de uma data final de semana (Sábado ou Domingo)
Saberexcel - dicas funções e fórmulas


Evite fins de semana usando fórmulas do Microsoft Excel, que fórnece a dia da semana útil mais perto da sua data de entrega
Digamos que você deva entregar em um dia útil mas a data mostrada em B2 está em um sábado ou no domingo.
Use esta fórmula para ser atriguido ao dia precedente na Sexta-feira e ou Segunda-Feira
(se a data for já um dia útil, ele mostrará somente a data na célula onde contém a fórmula)


Sugestão dia para embarque:

para obter a data sexta feira precedente a data na célula B2
Supondo que data seja ()....: 24/10/2010 (Domingo)
Fórmula usada................... : =MÍNIMO(A1-(DIA.DA.SEMANA(A1;2)-5);A1)
Retona da Fórmula..............: 22/10/2010 sexta-feira


Use esta fórmula mostrar a próxima Segunda feira, da data na célula B2, mostra a próxima segunda feira a essa data se for fim de semana
Supondo que data seja () 24/10/2010 (Domingo)
Fórmula usada...................: '=SE(DIA.DA.SEMANA(B2;2)>5;B2+(8-DIA.DA.SEMANA(B2;2));B2)
Retona da Fórmula.............: 25/10/2010 segunda-feira

ou

Retona da Fórmula.............: 25/10/2010 segunda-feira
Retona da Fórmula.............: =SE(DIA.DA.SEMANA(B2;2)>6;B2+(8-DIA.DA.SEMANA(B2;2));B2)



Concatenando dados para montar uma mensagem:
Msg: Se você tem um embarque para fazer nesta data [ 24-domingo-outubro-2010 ] sugiro que faça nesta data:[ sexta-feira-22-outubro-2010 ]

Fórmula usada:
="Se você tem um embarque para fazer nesta data [ "&TEXTO(A1;"dd-dddd-mmmm-aaaa")&" ] sugiro que faça nesta data:[ "&TEXTO(G11;"dddd-dd-mmmm-aaaa")&" ]




Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel



 
   Baixe o exemplo de planilha com as fórmulas acima
 Excel formulas evite fins de semana sabado e domingo no embarque (11.29 kB)

Última atualização em Sáb, 20 de Outubro de 2012 09:42  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje57
mod_vvisit_counterOntem5104
mod_vvisit_counterEsta Semana29821
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês43550
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10466379
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA