Home Excel - Formulas e Funções Excel Formulas - Data Tempo Idade Excel planilha formulas obtendo datas flutuantes duas datas

Excel planilha formulas obtendo datas flutuantes duas datas

E-mail Imprimir PDF

SaberExcel  - O site de quem precisa aprender Macros Microsoft Excel VBA

No Aplicativo Microsoft Excel há dois tipos de fazer as datas fluturarem. veja como

Para se obter o segundo no domingo no Maio usam o abaixo da fórmula.
onde a célula A1 é o ano (2010), célula A2 é 5 Maio e a célula A3
é o dia (1 durante o primeiro domingo, 2 durante a primeira Segunda-feira ...
o número máximo será 35 que ser igual ao quinto sábado (a assunção do mês de fato tem 5 sábados)

=SE(MÊS(DATA(A1;A2;1))<>MÊS(SE(DIA.DA.SEMANA(DATA(A1;A2;1)-(DIA.DA.SEMANA(DATA(A1;A2;1))-A3))<DIA.DA.SEMANA(DATA(A1;A2;1));DATA(A1;A2;1)+(A3-DIA.DA.SEMANA(DATA(A1;A2;1)))+7;DATA(A1;A2;1)-(DIA.DA.SEMANA(DATA(A1;A2;1))-A3)));"";SE(DIA.DA.SEMANA(DATA(A1;A2;1)-(DIA.DA.SEMANA(DATA(A1;A2;1))-A3))<DIA.DA.SEMANA(DATA(A1;A2;1));DATA(A1;A2;1)+(A3-DIA.DA.SEMANA(DATA(A1;A2;1)))+7;DATA(A1;A2;1)-(DIA.DA.SEMANA(DATA(A1;A2;1))-A3)))


Dia útil Passado
Se você quis o dia útil passado de um mês, use esta fórmula
(Esta fórmula calcula como em cima exceto há só 7 dias para selecionar, no domingo = 1, na Segunda-feira = 2.... No sábado = 7)
=SE(A2<>MÊS(DATE(A1;A2+1;0)-(DIA.DA.SEMANA(DATA(A1;A2+1;0))-A3));DATA(A1;A2+1;0)-(DIA.DA.SEMANA(DATA(A1;A2+1;0))-A3)-7;DATA(A1;A2+1;0)-(DIA.DA.SEMANA(DATA(A1;A2+1;0))-A3))

Melhorado!
Uma versão encurtada da acima mencionada fórmula durante o dia útil passado.

=DATA(A1;A2+1;0)-DIA.DA.SEMANA(DATA(A1;A2+1;0))+A3+SE(DIA.DA.SEMANA(DATA(A1;A2+1;0))<A3;-7;0)



Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel



Publicidade
Compre com segurança, garantia e ótimos preços
Eletrônicos - Submarino.com.br

Última atualização em Dom, 04 de Setembro de 2011 09:41  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4783
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana24984
mod_vvisit_counterSemana passada30982
mod_vvisit_counterEsse mês43172
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10466001
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA