Home Excel - Formulas e Funções Excel Formulas - Data Tempo Idade Excel formulas horas excel trabalhando com horas decimas

Excel formulas horas excel trabalhando com horas decimas

E-mail Imprimir PDF



 Saberexcel - site das macros
Fórmulas do aplicativo Microsoft Excel convertem formato 'horas 14:45:38' para formato decimal '14,.7,5'
Saberexcel - dicas do excel fórmulas e funções

Exemplos:
Célula(A1)
= 14:45:38
Fórmula Usada ......: =HORA(A1)&"."&SUBSTITUIR(MINUTO(A1)/6;".";"")
Retorno............... : 14.7,5

Use com o formato Geral para retorno do Decimal
Fórmula Usada ......: =24*A1
Retorno............... : 18:15:12


Fórmula também gera o mesmo resultado (Formato Geral)
Fórmula Usada ......: =HORA(A1)+(MINUTO(A1)/60)
Retorno................: 14,75


Fórmula também gera o mesmo resultado (Formato Geral)

Fórmula Usada ......: =HORA(A1)+(MINUTO(A1)/60)+(SEGUNDO(A1)/3600)
Retorno................: 14,76055556


Fórmula também gera o mesmo resultado (Formato Geral)
Fórmula Usada ......: =TEMPO(HORA(A1);MINUTO(A1);SEGUNDO(A1))*24
Retorno................: 14,76055556

Formula Allternativa
Fórmula Usada ......: =INT(4*(A1*24-INT(A1*24)))*0,25
Retorno................: 0,75


Fórmula usando a Função MARRED() para arredondar hora
para funcionar, instale Suplemento Ferramenta de Análise

Fórmula Usada ......: =((HORA(A1)*60)+MARRED(MINUTO(A1);15))/60
Retorno................: 14,75


Use a formatação PM e ou AM
Fórmula Usada ......: =SE(MOD(A1;12)=0;12;MOD(A1;12))
Retorno................: 2:45:38 PM



Aprenda tudo sobre o Aplicativo Microsoft Excel VBA com Saberexcel



 

   Baixe o exemplo de planilha microsoft excel contendo as fórmulas acima:
Excel formulas horas excel trabalhando com horas decimas (12.04 kB 2010-12-05 08:28:23)




Compre com segurança e garantia pela internet nas lojas Submarino

Última atualização em Dom, 04 de Setembro de 2011 09:44  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje348
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana25008
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês38737
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10461566
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA