Home Excel - Dicas Microsoft Excel VBA Excel VBA - Digitacao Excel planiha vba digitalçao validacao dados impede duplicados

Excel planiha vba digitalçao validacao dados impede duplicados

E-mail Imprimir PDF

Saberexcel - o site das macros
Essa macro do Aplicativo Microsoft Excel VBA, contém uma macro que impede o usuário de digitar dados duplicados, repetidos.
Observe que a interdição é partir da Validação de Dados do próprio Aplicativo Microsoft Excel VBA, através do Visual Basic
Application

Sub duplicados_validacao_dados()
''With Range("G1").Validation
With Range("A1:H10").Validation
.Delete
.Add Type:=xlValidateCustom, AlertStyle:=xlValidAlertStop, Operator:= _
xlBetween, Formula1:="''''=CONT.SE($A$1:$H$10;A1)=1"
.IgnoreBlank =
True
.InCellDropdown =
True
.InputTitle = ""
.ErrorTitle = "Numero Duplicado!"
.InputMessage = ""
.ErrorMessage = "Este número ja foi digitado!"
.ShowInput =
True
.ShowError =
True
End With
Range("I1").Select
End Sub

 


Aprenda tudos sobre o Aplicativo Microsoft Excel VBA (Visual Basic Application) com produtos didáticos SaberExcel



   Baixe o exemplo de planilha contendo a macro acima
Excel planilha vba digitacao planilhas desloc registra mudancas planilha (20.89 kB)


 

Última atualização em Sáb, 13 de Agosto de 2011 18:32  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje284
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana24944
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês38673
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10461502
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA