Home Excel - Dicas Microsoft Excel VBA Excel VBA - Datas Excel planilha vba datas funcao converte data ao digita insere barras

Excel planilha vba datas funcao converte data ao digita insere barras

E-mail Imprimir PDF

Saberexcel - site das macros

Funçao do Aplicativo Microsoft Excel VBA, converte datas digitadas em células, inserindo as barras de separação de datas dia, mes, ano,
por exemplo voce diigita : (*) Baixe o exemplo de planilha no final da página.  
Observe que fizemos uma formatação personalizada na coluna (Data Digitada) @ para aceitar o zero.

Espero tê-lo ajudado! - Fique com Deus, Boa sorte.

DATA DIGITADA - RETORNO - FUNÇAO USADA
01072012 01/07/2010 =SE(C6="";"";ConverteData(C6))
01052010 01/05/2010 =SE(C7="";"";ConverteData(C7
))

Funçao converte datas digitas inserindo as barras de separação:

Function ConverteData
(vdate) As Date
Application.Volatile
ConverteData = CDate(Left(vdate, 2) & "/" & Mid(vdate, 3, 2) & "/" & Right(vdate, 2))
End Function

Function RetornaFormula(vCelula As Range) As String
'Application.Volatile = True
RetornaFormula = vCelula.FormulaLocal
End Function


Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel




(*) -   ESSE EXEMPLO DE PLANILHA FAZ PARTE DOS MÓDULOS COMO FAZER - PROGRAMAÇÃO MS EXCEL VBA - SABEREXCEL

 Publicidade:
compre com garantia, segurança e ótimos preços, Lojas Submarino
Esporte & Lazer - Submarino.com.br

Última atualização em Sáb, 13 de Agosto de 2011 17:37  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje287
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana24947
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês38676
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10461505
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA