Home Excel - Dicas Microsoft Excel VBA Excel VBA - Cadastro Excel planilha vba cadastra userform agenda telefonica

Excel planilha vba cadastra userform agenda telefonica

E-mail Imprimir PDF

Saberexcel - o site de quem precisa aprender sobre macros Microsoft Excel VBA.

E
sses exemplos de macros e procedimentos do Aplicativo Microsoft Excel VBA, efetua um cadastro muito simples para um nível de  iniciantes, na folha de planiha atraves de objeto Formulário, textbox, labels, com sistema de busca simples, também obtido atraves de GM(Gravação de Macros) para a busca do ítem desejado. Na lição_1 do nosso CURSO COMPLETO MICROSOFT EXCEL VBA, falamos muito sobre como dominar esse conhecimento com Gravador de Macros, porque achamos muito importante para quem esta iniciando com desenvolvimento e programação de planilhas automatizadas. esse Exemplo de Planilha está em nosso DVD - 14.000 Planilhas Excel VBA - Treinamento e desenvovimento a partir de exemplos prontos. contém excelentes exemplos. Fiquem com Deus, Expedito Marcondes.

'--------------------------------------'
Private Sub BTN_Cadastrar_Click()
Dim NR As Long
  
  'VERIFICA SE OS DADOS FORAM DIGITADOS (TIPO verifica inconsistência)
   If TXT_TELEFONE.Text = "" Then
      MsgBox "Digite o telefone para cadastro.", vbinformtaion,"Saberexcel VBA Estudos®"
      TXT_TELEFONE.SetFocus
      Exit Sub
   ElseIf TXT_NOME.Text = "" Then
      MsgBox "Digite o nome do dono do telefone.", vbinformtaion,"Saberexcel VBA Estudos®"

      TXT_NOME.SetFocus
      Exit Sub
   End If
   
    Sheets("AGENDA").Select
    Range("A6").End(xlDown).Select
   
    NR = ActiveCell.Row
  
    Range("A65536").End(xlUp).Offset(1, 0).Select
       
   
    ActiveCell.Offset(0, 0).Value = lbNUM.Caption
   
    ActiveCell.Offset(0, 1).Value = TXT_TELEFONE.Text
    ActiveCell.Offset(0, 2).Value = TXT_NOME.Text
    ActiveCell.Offset(0, 3).Value = TXT_ENDERECO.Text
    ActiveCell.Offset(0, 4).Value = TXT_CIDADE.Text
    ActiveCell.Offset(0, 5).Value = TXT_TELEFONE.Text
   
                        
   TXT_TELEFONE.Text = ""
   TXT_NOME.Text = ""
   TXT_ENDERECO.Text = ""
   TXT_CIDADE.Text = ""
   TXT_TELEFONE.SetFocus
   
    Me.lbNUM = Sheets("AGENDA").Range("a65536").End(xlUp).Row + 0
End Sub

Private Sub BTN_Sair_Click()
  Unload Me
End Sub

Private Sub UserForm_Initialize()
  Me.lbNUM = Sheets("AGENDA").Range("a65536").End(xlUp).Row - 4
End Sub

Macro para gusca busca a ser efetuada pelos números dos telefones

Sub PESQUISA()
   Cells.Find(What:=Plan1.Cells(6, 2), _
   After:=ActiveCell, LookIn:=xlFormulas, _
   LookAt:=xlPart, SearchOrder:=xlByRows, _
   SearchDirection:=xlNext, _
   MatchCase:=False, SearchFormat:=False).Activate
End Sub

'- formula Formatação condicional .....
=SE($B6=$K$2;VERDADEIRO;FALSO)

fórmula usada.(k4) abaixo (Para busca de dados) via fórmula.
=SE(K2="";"";ÍNDICE($C$6:$C$44;CORRESP(K2;$B$6:$B$44;0);1))



Aprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Escola Saberexcel VBA Estudos® - Treinamentos com Macros, Fórmulas e Funções.



    Baixe o exemplo de planiha contendo os procedimentos acima.
      Excel planilha vba cadastra userform agenda telefonica (91.82 KB)

Última atualização em Dom, 16 de Outubro de 2011 10:31  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje4447
mod_vvisit_counterOntem5154
mod_vvisit_counterEsta Semana29107
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês42836
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10465665
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA