Home Excel - Dicas Microsoft Excel VBA Excel VBA - Formulas e Funcoes Excel planilha vba formulas transforma abolutas em relativas e vice versa

Excel planilha vba formulas transforma abolutas em relativas e vice versa

E-mail Imprimir PDF

Saberexcel - o site das macros

Esta macro do Aplicativo Microsoft Excel VBA, transforma as formulas relativas em fórmulas absolutas
Macro do Aplicativo Microsoft Excel VBA, transforma as fórmulas absolutas em fórmulas relativas e vice versa

Sub Formulas_relativa_absoluta()
[E21].Select
ActiveCell.Formula = Application.ConvertFormula _
(Formula:=ActiveCell.Formula, _
fromReferenceStyle:=xlA1, _
toAbsolute:=xlAbsolute)
[G21].Value = "<< ' =SOMA($B$17:$B$26) ( A B S O L U T A S )"
End Sub

Sub Formulas_absoluta_relativa()
[E21].Select
ActiveCell.Formula = Application.ConvertFormula _
(Formula:=ActiveCell.Formula, _
fromReferenceStyle:=xlA1, _
toAbsolute:=xlRelative)
[G21].Value = "<< ' =SOMA(B17:B26) << R E L A T I V A S >> "
End Sub

 

Especifica o estilo de referência de célula quando uma fórmula está sendo convertida.

Informação sobre versão
Version adicionada: Excel 2007

NomeValorDescrição
xlAbsolute 1 Converte para linha absoluta e estilo de coluna.
xlAbsRowRelColumn 2 Converte para linha absoluta e estilo de coluna relativa.
xlRelative 4 Converte para linha relativa e estilo de coluna.
xlRelRowAbsColumn 3 Converte para linha relativa e estilo de coluna absoluta.





AAprenda tudo sobre planilhas do Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel



   Baixe o exemplo de planilha com as macros acima
Excel planilha vba formulas transforma abolutas em relativas e vice versa (15.6 kB)

Última atualização em Sáb, 13 de Agosto de 2011 18:46  

Adicionar comentário

"Jamais considere seus estudos como uma obrigação, mas como uma oportunidade invejável para aprender a conhecer a influência libertadora da beleza do reino do espírito, para seu próprio prazer pessoal e para proveito da comunidade." Albert Einstein


Código de segurança
Atualizar

Pesquisa Google SaberExcel

Publicidade Google

Publicidade

Rastreamento Correios

Digite o número do SEDEX conforme o exemplo:
Correios do Brasil

Assinatura SaberExcel

Google Associados

Depoimentos

Visitantes SaberExcel

Excel VBA Estudos®
mod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_countermod_vvisit_counter
mod_vvisit_counterHoje1719
mod_vvisit_counterOntem5672
mod_vvisit_counterEsta Semana11850
mod_vvisit_counterSemana passada36487
mod_vvisit_counterEsse mês25579
mod_vvisit_counterMês passado153723
mod_vvisit_counterTodos10448408
Aprenda MS Excel VBA

Adicione Saberexcel Favoritos

 
 

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


   Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA