Home Excel - Downloads / Areas Restritas Excel VBA - Combustivel

Excel VBA - Combustivel

  • - Acesso Livre
  • Documentos

    Ordenar por : Nome | Data | Acessos [ Descendente ]

    vba combustivel verifica abastecimento alcool vba combustivel verifica abastecimento alcool

    popular!
    Adicionado em: 03/02/2011
    Modificado em: 03/02/2011
    Tamanho: 113.41 KB
    Downloads: 1829

    Saberexcel - site das macros
    Esse exemplo de Planilha do Aplicativo Microsoft Excel VBA(Visual Basic Application) está equipado com macros e fórmulas que verifica o preço do combustível Álcool em relação à Gasolina. - Se o preço estiver abaixo de 70% do valor, fórmula calculará o percentual de diferença com o preço da gasolina e retornará o valor que está economizando com relação à gasolina, fornecendo o percentual e valor, quando o valor for favorável ao preço do Álcool, uma macro ligada ao Evento Worksheet_Change da Folha de Planilha mostra uma mensagem "Natureza Ganhando", se for gasolina "Natureza Perdendo"

    Pedido: Sr. Marcondes precisamos de uma planilha para expor em nosso site, que calcula o preço Alcool X Gasolina, e uma retorna a porcentagem e Valor (acima ou abaixo - calculandos perdas ou ganho) - (Manteremos um link para seu site, como agradecimento) - Gilberto.
    R.: Prezado, Gilberto, segue a planiilha conforme sua solicitação, adpte segundo às suas necessidades.
    Fique com Deus, - E_Marcondes - SaberExcel





    FÓRMULA USADA PARA O RETORNO DA MENSAGEM:
    =SE(G26>=G20;"Cuidado preço álcool não compensa "&TEXTO(G26-G20;" #0,00%")&" acima! você estará perdendo"&TEXTO(G24*SOMA(G26-G20);" R$#0,00")& " por litro";SE(G26<G20;"Compensa, pois a diferença está em :"&TEXTO(G20-G26;" #0,000%")&" você está lucrando "&TEXTO(G24*SOMA(G20-G26);"R$#0,00")&" por litro"))

    Observe a macro usadas para mostrar o shapes(Autoforma) muito simples.

    MACRO USADA
    Private Sub Worksheet_Change(ByVal Target As Range)
    If Range("O22").Value = 1 Then
    ActiveSheet.Shapes("sna").Visible = True
    ActiveSheet.Shapes("snab").Visible = False
    ActiveSheet.Shapes("ntg").Visible = False
    ActiveSheet.Shapes("ntp").Visible = True
    Else
    ActiveSheet.Shapes("snab").Visible = True
    ActiveSheet.Shapes("sna").Visible = False
    ActiveSheet.Shapes("ntg").Visible = True
    ActiveSheet.Shapes("ntp").Visible = False
    End If
    End Sub



    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos SaberExcel



    Google Associados

    Depoimentos

    Adicione Saberexcel Favoritos

     
     

    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA

    Aprenda tudo sobre o Aplicativo Microsoft Excel VBA(Visual Basic Application), sozinho, com baixo custo, praticando com os produtos didáticos Saberexcel,


       Sobre as WorksheetFunctions Funções de Planilhas que retornam valores do VBA